Vodafone Mobile Connect Card driver para Linux

Para quem usa a net móvel da vodafone existe uma aplicação desenvolvida pela Vodafone Espanha que nos permite ligar à internet sem termos de recorrer ao wvdial, ao Gnome-ppp ou ao kppp para além de nos permitir enviar sms!

A aplicação é open source (disponibilizada com a licença GPL v2) e desenvolvida em PyGtk. Funciona bastante bem efectua a ligação mais rápido do que as alternativas existentes. Infelizmente ainda não está nos repositórios do Ubuntu e não tenho conhecimento que esteja no Debian também. Mas nada temam, a vodafone disponibiliza binários para várias versões do Ubuntu, incluindo o Gutsy , Debian, Fedora e opensuse. Podem fazer o download aqui. Aconselho a utilizarem a versão 1.0, porque com a 1.99 a velocidade era bastante reduzida quando testei, talvez por não estar compilada para Gutsy e estar em desenvolvimento ainda.

Após transferir o binário para a sua distro, é só instalar usando o Gdebi ou dpkg em Ubuntu/Debian. Em outras distros utilize o seu o gestor de pacotes (yum, yast). Um ícone da vodafone irá aparecer em Aplicações —> Internet (Isto em Gnome, em Kde deverá ser semelhante). Depois abra o programa e faça o seguinte:

Ir a

Tools —> Preferences

em connection preencher da seguinte forma:

Username: vodafone

Password: vodafone

Prefered connection: 3G prefered

APN Host: internet.vodafone.pt

Marcar a caixa que diz: Use static nameservers

e preencher os DNS

Primary DNS: 212.18.160.133

Secundary DNS: 212.18.160.134

Marcar também a caixa: Manage my /etc/ppp/…

E pronto! Já está! mais simples é difícil!

Existe também a aoção de desactivar/activar e alterar o pin. Vá a:

Tools —> Chage pin

Tools —> Request pin

#Debian#driver#Fedora#internet#linux#opensuse#ubuntu#vodafone

Comments

  1. linus - 8 de Fevereiro de 2008 @ 12:57

    instalei o programa, utilizando o comando yum no fedora Core 7. é-me pedido o pin da placa, só que ao clicar no botão connect nao acontece nada , embora o botão esteja activo.

  2. amrlima - 8 de Fevereiro de 2008 @ 19:51

    A placa funciona com o wvdial, ou outra aplicação ex. gnome-ppp ou kppp? Desactivaste o pin? verificaste se os DNS estão correctos? Qual foi a versão do programa que instalaste? o 1.0? Podem ser várias coisas… espero que consigas! Boa sorte! qualquer questão é só perguntar!

Deixe uma resposta

Este site utiliza o Akismet para reduzir spam. Fica a saber como são processados os dados dos comentários.