Firefox 3 beta no Ubuntu Gutsy

Andei a vasculhar a web à procura de debs da versão beta do firefox 3. Depois de alguma pesquisa (coisa de 5 minutos) encontrei um repositório de um dos maintainers do firefox. Para usarmos a beta2, a mais recente para gutsy, mas a 3 já existe para hardy, adiciona-se os seguintes repositórios ao /etc/apt/sources.list:

deb http://ppa.launchpad.net/fta/ubuntu gutsy main
deb-src http://ppa.launchpad.net/fta/ubuntu gutsy main

depois é fazer o procediemento do costume…

sudo apt-get update

e instalar os pacotes firefox-3.0 e firefox-3.0-gnome-support com o apt-get.

E pronto, temos uma versão bem actual do firefox que, pelo que usei está bastante estável e com novas funcionalidades muito úteis… mas isso vejam por vocês mesmos…

Se ficarem frustrados por as vossas extenções e dicionários não funcionarem com o firefox 3 não desesperem! Dêm vida ao vosso lade de hacker e mexam no código das vossas extensões favoritas!

Transfirem daqui a vossa extensão favorita, fazendo “save link as” em vez de “install now” e extraiam (se estiverem em linux) o ficheiro .xpi. Depois abram com o gedit (ou outro editor de texto) o ficheiro “install.rdf” e alterem onde está o número da versão, normalmente 2.0.0* para 3.0. Depois, com o ficheiro .xpi aberto adicionem o “install.rdf” alterado e arranstem o novo .xpi para os addons do firefox. E pronto, a extensão instala normalmente!

Extensões testadas:

Scribefire
Post to Delicious
UnPlug
Dicionário Português PT e BR

Infelizmente o dicinário português PT não funciona no Scribefire… Mas de resto é perfect!

Bom hacking!!

Update:
O firefox 3 tem um problema com o java, que não funciona, pelo menos no gutsy (acho que no hardy esse problema não existe). Para soluccionar esse problema é necessário fazer um sym link do java plugin para a pasta de plugins do Firefox fazendo o seguinte:

cd .mozilla/plugins/ e

ln -s /usr/lib/jvm/java-6-sun-1.6.0.03/jre/plugin/i386/ns7/libjavaplugin_oji.so libjavaplugin_oji.so


Caso tenham o Adblock, esse poderá afectar a iniciação das applets java. Se tiverem problemas é só desactivar o adblock temporariamente. Isto também acontece no Firefox 2.0!

Update: A beta 3 do firefox já saiu e esta encontra-se nos repositórios do Ubuntu. Para isso basta activarem o backports e instalarem o firefox beta3.

Faz-se o seguinte:

Sistema – Administração – Gestor de Pacotes Synaptic

Definições – Repositorios – Separador Actualizações

Activar “Unsuportted Updates (gutsy-backports)“, fechar, e carregar em ACTUALIZAR

Depois procure e instale no Synaptic ou com o apt-get os pacotes firefox-3, firefox-3-gnome-support e xulrunner-1.9

As restantes betas também devem já estar nesse repositório

Fonte deste update: http://www.formatds.org/firefox-3-beta-3-ubuntu-gutsy/

Technorati Tags: , , , , ,

Powered by ScribeFire


If you want to follow this post leave a comment bellow and continue the thread, or sbscribe the feed. If you don't have a feed reader you may subscribe by e-mail. Click here to sign up.

Ainda sem comentários.

Deixe o seu comentário

Line and paragraph breaks automatic, e-mail address never displayed, HTML allowed: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

(obrigatório)

(obrigatório)